1.7 için uyumlu mu acaba?